Solved

Bamboo HR integration error: "Report does not exist"

  • 30 May 2023
  • 4 replies
  • 119 views

Userlevel 2
Badge +1

Hi Pigment Support,

 

I’ve integrated Bamboo with our workforce planning app via API Token.

However, when I try to import a report get the error “Report does not exist”.
I know the report exists in Bamboo, and I have double checked the report ID which is definitely right.

We have also integrated Bamboo with other services we use without issue.

Any hints on how to fix this?

Thanks!
Naomi

icon

Best answer by Naomi Vriend 1 June 2023, 15:46

View original

4 replies

Userlevel 3
Badge

Hi Naomi,

Thanks for sharing your case with the community.
However, if you are confident about your integration, and the existence of the report in Bamboo, then I would recommend opening a Help Desk case.
I am afraid that by not having access to your model nor the back end we might be of poor help in that situation. 
The Pigment support will have access to all that and will be able to investigate properly.

You can very simply raise a case from within Pigment by clicking on this little icon (top left): 

Hope that helped a little.
Please let me know if any other information is needed.

Userlevel 2
Badge +1

Hi Fabien,

Thank you, I’ve submitted a request via the Contact Us form.

Cheers!

Userlevel 2
Badge +1

Update: fixed!


The issue was that the API key used in setting up the Bamboo integration in Pigment was a user which didn’t have access to that Bamboo report. So the report couldn’t pull. When we set up the integration again using our Bamboo administrator’s API Key, the report pulled.

tldr: the API Key should be generated by a Bamboo user with full access to all reports.

Userlevel 3
Badge

Hi Naomi,
Thank you very much for letting us know the reason!

Reply