Error: Unknown List Property: Country mapping.'Country Group'

  • 31 October 2023
  • 2 replies

Userlevel 1
Badge +1

Hi, good morning everyone!


I have an error and I can’t solve it, could you help me out with a solution please?


I have the formula: 'All Deals'.'Deal ID'[BY COUNT: 'All Deals'.'Country/Region'.Country.'Group', 'All Deals'.Segment.'Segment Simplified', 'All Deals'.Pipeline.'Pipeline Simplified', 'All Deals'.'Create Month']

Every time I try to run the formula I get the error: Error: Unknown List Property: Country mapping.Country


For more context: All Deals is a transaction list that has various dimensions and lists within it. I am trying to build a formula that will have the country group on the y-axis and month on the y-axis. I have used the dimension “Country mapping” to convert all the different languages of countries to english. The dimension “Country mapping” has a dimension called “Countries english names” that comes from the “Country” Dimension, specifically the ‘english’ column. Using my formula I expect to call the “country mapping” dimension and then through its associated property call the “country” table to then organize my formula using the “group” dimension I have in my “Country” dimension. Unfortunately I keep getting an error and cannot understand why pigment will not allow me to push through from “country mapping” to “country” to then call on other dimensions. Additionally, I know that my “country” and “country mapping” are connected because when looking at the library & usages section it shows that “country mapping” is being used.


I have tried various methods but at this point have no further ideas and am hoping one of you have a solution in mind. Thank you for your assistance. 


Transaction List: “All Deals” (formula comes off this)
Dimension: “Country mapping” (dimension that gives me country names in english)
Dimension: “Country” (dimension for english country names)
Library & Usages of dimension “Country” - pigment is even showing the relationship exists
Error when trying to run formula - (unable to call my ‘country’ dimension)



Best answer by Benoit 2 November 2023, 10:19

View original

2 replies

Userlevel 6
Badge +12



From what I see,

the mapping should be done using the mapping: Country mapping.’Countries English Name’.Group

Which means this part of the formula should look like:

'All Deals'.'Country/Region'.’Countries English Name’.Group


This is because in your Country Mapping dimension, there is no property called “Country”. 

You only have 

  • Countries (text)
  • Countries English Name (Country dimension)

So to call the Country dimension, you have to tell Pigment the name of the property.

Then, even if it’s not written “Country”, it is using the Country dimension, so you can call the other mappings like “Group”.


A best practice is to always name your dimension type properties the same way than the dimension used. This avoids confusion and is more straight forward when building formulas.


Hope it helps.

Let us know.

Userlevel 1
Badge +1

Hi Benoit,


I just tested out your solution and it worked perfectly! 

I’ll definitely be keeping the dimension type properties the same in the future to avoid this confusion.


Thank you for your help!