Solved

Filter data with formula

  • 18 July 2022
  • 4 replies
  • 71 views

Badge

Hi, good afternoon everyone!

I have an error and I can't solve it, could you help me with the solution, please?

I have the formula: 'Bonus per year (euros)'[BY CONSTANT: Month.Year][FILTER: Month.'Month
of Year'='Month of Year'."December"]

I got error return: " Error: Unknown List Property: Month.'Month
of Year' "

But when I go to check the Month dimension, I see the list.

Can you help me please?

Thanks!

icon

Best answer by Nathan 18 July 2022, 16:45

View original

4 replies

Userlevel 4
Badge +4

Hi,

 

when I copy this string: Month.'Month
of Year'='Month of Year'."December"
into Pigment, I get an error.
You have a hidden character that makes a line break. Try to retype it or copy this:

Month.'Month of Year'='Month of Year'."December"

Badge

'Bonus per year (euros)'[BY CONSTANT: Month.Year][FILTER: Month.'Month
of Year'='Month of Year'."December"]

I put this formula but it still gives error so checked the month dimension and the list exists there.

But the error persists.

Thanks!

Userlevel 4
Badge +4

that was just a copy of yours. Try the updated one I shared

Badge

Hi,

 

when I copy this string: Month.'Month
of Year'='Month of Year'."December"
into Pigment, I get an error.
You have a hidden character that makes a line break. Try to retype it or copy this:

Month.'Month of Year'='Month of Year'."December"

Hi Nathan!

I think it was the copy and paste of the course pdf.

Thank you very much!

Have a good day

 

Reply