Formula error - timed out

  • 22 February 2024
  • 3 replies

Userlevel 4
Badge +7


I am trying to calculate the number of employees who left by hire date cohort and number of months that they stayed in the society. Here is the formula I have (but doesn’t work because it is too complicated I think):

Employee [BY COUNT: Employee.'Cohort Month', Employee.'Month tenure cohort', Employee.Country, Employee.'First Job Position'.'Team Graph HR']

The Cohort month corresponds to the month of arrival.

The Month tenure cohort corresponds to the number of months the employee stayed in the society.

I want this metric by team department (Team Graph HR) of their first job position (because some employees can evolve from one job to another in the company).

Could you please help me finding the best formula here?




Best answer by Elodie 23 February 2024, 16:35

View original

3 replies

Userlevel 2
Badge +9

Hi Elodie,

The formula does not seems to complicated in itself. Some questions :

  • Employee.'First Job Position'.'Team Graph HR' is a sub-property or a property coming from a metric ?
  • What are the dimension of the target metric ? If it is only Team Graph HR the formula should be Employee [BY COUNT: Employee.'First Job Position'.'Team Graph HR']

Final advice, you should use the playground to test this formula with “automatic structure” set on to help you refine target dimension.

Userlevel 6
Badge +12

Hi, I’m jumping on this conversation as a Support ticket was also raised for this situation.


In this case, your formula is correct and optimized.

‘Team Graph HR’ is a parent dimension of ‘First Job Position’ so the chain is correct.


CamilleMomo is right, using the formula playground in automatic mode is the best action you can take to get your results with the appropriate structure.


If it times out, it is either because of a technical issue or very high cardinality. An error message should indicate it to you and Support should be the best route.


Here, I believe you had “no access “and the formula seemed to not compute. 

To understand if it’s an Access Rights configuration situation, you can try to add a resetaccessrights() over your formula and see if it resolves the issue.

If yes, then it’s best to try to understand where the rights are lost.

If no, then it requires further modeling investigation.





Userlevel 4
Badge +7

Yes the problem is solved and was due to an Access Rights configuration situation. I added the RESETACCESSRIGHTS function and it seems to have worked.